Configuring Multipoint OSPF using Network type Point-to-Multipoint

R1#sh run
!
Output Omitted
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 multipoint
 ip address 10.2.123.1 255.255.255.248
 ip ospf network point-to-multipoint
 frame-relay interface-dlci 102
 frame-relay interface-dlci 103
!
end

R1#sh ip ospf neighbo

Neighbor ID     Pri   State           Dead Time   Address         Interface
3.3.3.3           0   FULL/  -        00:01:50    10.2.123.3      Serial0.1
2.2.2.2           0   FULL/  -        00:01:51    10.2.123.2      Serial0.1
R1#sh ip ospf interface s0.1
Serial0.1 is up, line protocol is up
  Internet Address 10.2.123.1/29, Area 0
  Process ID 1, Router ID 1.1.1.1, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:13
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 4 msec, maximum is 4 msec
  Neighbor Count is 2, Adjacent neighbor count is 2
    Adjacent with neighbor 3.3.3.3
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)
R1#

R2#sh run
!
Output Omitted
!
interface FastEthernet0
 no ip address
 shutdown
 speed auto
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 multipoint
 ip address 10.2.123.2 255.255.255.248
 ip ospf network point-to-multipoint
 frame-relay map ip 10.2.123.3 101 broadcast
 frame-relay interface-dlci 101
!
router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
end

R2#sh ip ospf neig

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:01:54    10.2.123.1      Serial0.1
R2#sh ip ospf interface s0.1
Serial0.1 is up, line protocol is up
  Internet Address 10.2.123.2/29, Area 0
  Process ID 1, Router ID 2.2.2.2, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:17
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 4 msec, maximum is 4 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1
  Suppress hello for 0 neighbor(s)
R2#

R3#sh run
Building configuration...

Current configuration : 933 bytes
!
Output Omitted
!
interface Serial0
 no ip address
 encapsulation frame-relay
!
interface Serial0.1 multipoint
 ip address 10.2.123.3 255.255.255.248
 ip ospf network point-to-multipoint
 frame-relay map ip 10.2.123.2 101 broadcast
 frame-relay interface-dlci 101
!
router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
 network 10.0.0.0 0.255.255.255 area 0
!
end

R3#sh ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
1.1.1.1           0   FULL/  -        00:01:43    10.2.123.1      Serial0.1
R3#sh ip ospf interface s0.1
Serial0.1 is up, line protocol is up
  Internet Address 10.2.123.3/29, Area 0
  Process ID 1, Router ID 3.3.3.3, Network Type POINT_TO_MULTIPOINT, Cost: 64
  Transmit Delay is 1 sec, State POINT_TO_MULTIPOINT,
  Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
    oob-resync timeout 120
    Hello due in 00:00:07
  Index 1/1, flood queue length 0
  Next 0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1
    Adjacent with neighbor 1.1.1.1
  Suppress hello for 0 neighbor(s)
R3#

Configuring Multipoint OSPF using Network type Point-to-Multipoint NonBroadcast

For point-to-multipoint nonbroadcast, not much different with configuration above, just change :

  • ip ospf network point-to-multipoint non-bradcast in sub interface command, and
  • define the neighbor 10.2.123.x  in ospf sub command

there is no different output if we try show ip ospf interface s0.1 command, but this table will show you ospf network type comparison.