iBGP eBGP topology

Note : C1 adalah cloud yang merupakan simulasi 2 buah PC yang berbeda. PC1 merupakan user di network R1, ip:172.16.1.2/24. Sedangkan PC2 merupakan user di network R3, ip:10.3.3.2/24. Untuk simulasi PC ini saya menggunakan software vpcs yang bisa terintegrasi dengan GNS3.

Berdasarkan topologi diatas, ada dua konfigurasi iBGP yang bisa diterapkan. Yang pertama peering ke interface point-to-point, yang kedua peering ke loopback. Disini akan dibahas satu persatu, dan bisa dilihat perbedaan konfigurasinya.

Peering Point-to-Point

Konfigurasi :

R1#sh run | begin interface
interface FastEthernet0/0
 ip address 10.2.2.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 172.16.1.1 255.255.255.224
 duplex auto
 speed auto
!
router bgp 65010
 no synchronization
 bgp log-neighbor-changes
 network 172.16.1.0 mask 255.255.255.224
 neighbor 10.2.2.1 remote-as 65010
 no auto-summary

R2#sh run | begin interface
interface FastEthernet0/0
 ip address 10.2.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.1.1.1 255.255.255.252
 duplex auto
 speed auto
!
router bgp 65010
 no synchronization
 bgp log-neighbor-changes
 neighbor 10.1.1.2 remote-as 65020
 neighbor 10.2.2.2 remote-as 65010
 neighbor 10.2.2.2 next-hop-self
 no auto-summary

R3#sh run | begin interface
interface FastEthernet0/0
 ip address 10.1.1.2 255.255.255.252
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 10.3.3.1 255.255.255.0
 duplex auto
 speed auto
!
router bgp 65020
 no synchronization
 bgp log-neighbor-changes
 network 10.3.3.0 mask 255.255.255.0
 neighbor 10.1.1.1 remote-as 65010
 no auto-summary

Pada konfigurasi diatas, seluruh network point-to-point tidak di advertise ke BGP.

Lihat di BGP R2 jika tidak menambahkan next-hop-self maka R2 mengirim update ke R1 tanpa mengubah next-hop nya, in this case R2 akan mengirim ke R1 informasi network 10.3.3.0/24 dengan next hop origin 10.1.1.2 milik R3 (verifikasi : “sh ip bgp”). Lalu R1 akan melihat ke routing table apakah terdapat routing ke 10.1.1.2, karena tidak ada maka network 10.3.3.0/24 unreachable. Dengan menambahkan command next-hop-self ke arah neighbor R1 maka infomasi routing yang dari luar AS akan diberikan next-hop ip directly connected (10.2.2.1). Sebetulnya jika semua network point-to-point di advertise ke dalam BGP, issue tersebut tidak akan muncul, karena di routing table akan terdapat seluruh ip point-to-point nya.

Verifikasi :

R1#sh ip bgp
BGP table version is 12, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
 r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i10.3.3.0/24 10.2.2.1 0 100 0 65020 i
*> 172.16.1.0/27 0.0.0.0 0 32768 i
R1#

hasil ping PC
Gambar : Hasil Ping test PC1 dan PC2

Peering Loopback

Konfigurasi :

R1#sh run | be interface
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.2.2.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.1 255.255.255.224
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 1.1.1.1 0.0.0.0 area 0
network 10.2.2.0 0.0.0.255 area 0
!
router bgp 65010
no synchronization
bgp log-neighbor-changes
network 172.16.1.0 mask 255.255.255.224
neighbor 2.2.2.2 remote-as 65010
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

R2#sh run | be interface
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.2.2.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.1.1 255.255.255.252
duplex auto
speed auto
!
router ospf 2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
network 10.2.2.0 0.0.0.255 area 0
!
router bgp 65010
no synchronization
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 65010
neighbor 1.1.1.1 update-source Loopback0
neighbor 3.3.3.3 remote-as 65020
neighbor 3.3.3.3 ebgp-multihop 2
neighbor 3.3.3.3 update-source Loopback0
no auto-summary

R3#sh run | be interface
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.1.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.3.3.1 255.255.255.0
duplex auto
speed auto
!
router ospf 3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 10.1.1.0 0.0.0.3 area 0
!
router bgp 65020
no synchronization
bgp log-neighbor-changes
network 10.3.3.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 65010
neighbor 2.2.2.2 ebgp-multihop 2
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

Pada konfigurasi diatas menggunakan loopback sebagai peering. Ini lebih memudahkan engineer untuk mengetahui seluruh bgp peer yang ada di network, karena bila menggunakan peer ip point-to-point akan berbeda informasi ip next-hop di setiap node. contohnya misal engineer mengetikkan command “sh ip bgp” di R1, maka informasi yang diterima next-hop nya di ip 10.2.2.1. Sedangkan jika engineer mengetikkan command “sh ip bgp” di R3, maka informasi yang diterima next-hop nya di ip 10.1.1.1, padahal kedua ip tersebut sama-sama berasal dari R2.

Jika menggunakan peering loopback, maka harus di konfigurasi IGP terlebih dahulu (contoh diatas menggunakan OSPF). IGP berfungsi sebagai jembatan yang menguhubungkan network loopback di setiap node. Jika setiap loopback sudah reachable, BGP akan bisa peering ke setiap neighbor. Disamping itu, harus ditambahkan command “update-source loopback 0”, untuk state peering dikukan ke interface loopback bukan interface point-to-point.

Untuk peering eBGP harus ditambahkan command “ebgp-multihop 2” karena peering ke interface loopback melalui dua hop (hop 1 ke point-to-point, hop 2 ke loopback).

Verifikasi :

R1#show ip bgp
BGP table version is 33, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
 r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*>i10.3.3.0/24 3.3.3.3 0 100 0 65020 i
*> 172.16.1.0/27 0.0.0.0 0 32768 i
R1#
R3#sh ip bgp
BGP table version is 25, local router ID is 10.3.3.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
 r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.3.3.0/24 0.0.0.0 0 32768 i
*> 172.16.1.0/27 2.2.2.2 0 65010 i
R3#